Back to overview
Resolved

EU auth service timeout

Jul 3, 2026 at 2:01am UTC
Affected services
Auth service (Europe)

Resolved
Jul 3, 2026 at 2:52am UTC

We have applied a temporary fix, and the EU service should be operating normally now. We are continuing to investigate the root cause.

Created
Jul 3, 2026 at 2:01am UTC

We acknowledge that the EU service is experiencing timeouts. We are investigating the issue and will share updates as soon as we have more information.