Back to overview
Downtime

Cloud and US service down

Apr 16 at 01:21am HKT
Affected services
Cloud service
Auth service (US)

Resolved
Apr 16 at 01:35am HKT

Incident Summary

Logto Cloud and US Auth services experienced approximately 7 minutes of downtime due to an unplanned disruption during a computing resource SKU upgrade.

Root cause

The downtime was caused by a SKU change in our cloud provider’s compute resources, which doesn't support 0 downtime. The upgrade process led to temporary unavailability as instances were replaced and rescheduled.

Resolution

Once the issue was identified, the team monitored the redeployment and confirmed service recovery within minutes. No manual intervention was required beyond observation.

Action Items

  • Improve pre-upgrade impact assessment for infrastructure changes.
  • Explore zero-downtime deployment strategies for compute upgrades.

We sincerely apologize for the inconvenience and are committed to preventing similar incidents in the future.

Updated
Apr 16 at 01:28am HKT

Services are back online.

Created
Apr 16 at 01:21am HKT

We acknowledge that our Cloud and US Auth services are currently down, and we are investigating the issue.